Mavericks or newer will be required for the next major Photoshop release

Posted on by Elliot Jackson

Jeff Tranberry, Senior Product Manager at Adobe:

In order to leverage the latest operating system features and technologies, the next major release of Photoshop CC will require Mac OS X 10.9 (Mavericks) or above.

Customers running older versions of Mac OS X, such as 10.7 (Lion) and 10.8 (Mountain Lion), can continue to run and install the current Creative Cloud applications, but will not be able to install or run the next major release of Photoshop until they upgrade to a supported version of OS X.

Posted in Photoshop